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CHAPTER 1 PREDEFINED REPORTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Microsoft Project features a number of built-in reports.  

Not to be confused with the standard printing features of Microsoft 
Project, the reports are actually made up from data across the two 
tables, tasks and resources, and specific views and filters. 

They are based on settings rather than views of data on the screen. 
Hence they are predefined. 

Special Note: You’ll need Microsoft Office Service Pack 1 or later to 
be installed for some of the features in this chapter to work. There 
was a bug in versions prior to Service Pack 1 which prevented 
Custom Reports (which are dealt with here) from displaying on the 
screen. 

In this session you will: 

 gain an understanding of predefined reports 

 learn how to use a predefined report 

 learn how to use report lists 

 learn how to modify an existing report 

 learn how to run a crosstabulation report 

 learn how to dissect a crosstabulation report 

 learn how to create a crosstabulation report 

 learn how to adjust the details and sort order in a custom 
report 

 learn how to share a custom report with other projects. 
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UNDERSTANDING PREDEFINED REPORTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Microsoft Project will allow you to print or preview 
the view that is currently on the screen. This 
makes it very easy to obtain instant information 
about the status of your project. However, 

Microsoft Project also features 22 predefined 
reports that provide key information about your 
project. These reports can be printed at any time 
no matter which view you currently have. 

The Predefined Reports 

There are 22 predefined, built-in reports in Microsoft Project which have been categorised as 
shown below. 

Category Report Name 

Overview Project Summary 

Top-Level Tasks 

Critical Tasks 

Milestones 

Working Days 

Current 
Activities 

Unstarted Tasks 

Tasks Starting Soon 

Tasks In Progress 

Completed Tasks 

Should Have Started Tasks 

Slipping Tasks 

 

 

Category Report Name 

Costs Cash Flow 

Budget 

Overbudget Tasks 

Overbudget Resources 

Earned Value 

Assignments Who Does What 

Who Does What When 

To-do List 

Overallocated Resources 

Workload Task Usage 

 Resource Usage 

 

 Custom Reports 

In addition to the 22 reports that 
are already in Microsoft Project 
you can define your own custom 
reports. This is done by choosing 
a specific layout and then adding 
the bits and pieces you need to 
create your own custom report. 

The reports are accessed from 
the Reports command in the 
Reports grouping on the 
Project tab of the Ribbon. 
When you choose this 
command a Reports dialog 
box will appear showing six 
report categories. 

Sam
ple



Microsoft Project 2010 - Level 3 

© Watsonia Publishing Page 3 Predefined Reports 

USING A PREDEFINED REPORT 
 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Before starting this 
exercise you MUST open 
the file J420 
Reports_1.mpp... 


Click on the Project tab 
on the Ribbon and click 
on Reports in the 
Reports grouping to see 
the Reports dialog box 


Click on Current and click 
on [Select] to see 
Current Activity Reports 


Click on Unstarted Tasks 
and click on [Select] to 
preview the report 


If the report appears in 
multiple pages click on 
the first page to zoom it 


Click on the Project tab, 
click on Reports, click on 
Costs and click on 
[Select] to see the Cost 
reports 


Click on Budget and click 
on [Select] to preview the 
report 


If the report appears in 
multiple pages click on 
the first page to zoom it 


Click on the Project tab to 
return to the project – 
repeat the above steps 
and try some of the other 
reports 

 

For Your Reference… 

To use a predefined report: 

1. Click on the Project tab and click on 
Reports 

2. Click on a category and click on [Select] 

3. Click on a report and click on [Select] 

Handy to Know… 

 Once a report is in the preview screen it is 
like any other printing job. It can be seen with 
multiple pages or as a single page, and it can 
rescaled. Some options, however, such as 
headers, footers, and legends may be 
switched off. 

 

1 
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The predefined reports in Microsoft Project can 
be found in the Reports dialog box. This dialog 
box is broken down into a further six areas each 
with its own group of reports. The Reports dialog 

box is accessed from the Reports command on the 
Project tab of the Ribbon. When you click on a 
report you will be able to select it so that you can 
see it or edit it to make changes to the layout. 
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USING REPORT LISTS 
 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J420 Reports_1.mpp... 


Click on the Project tab on 
the Ribbon and click on 
Reports in the Reports 
grouping to see the 
Reports dialog box 


Click on Custom and click 
on [Select] to see the 
Custom Reports dialog 
box which lists all of the 
predefined reports 


Click on Base Calendar 
and click on [Select] to see 
the report in a preview 
window 


If the report appears in 
multiple pages click on the 
first page to see the detail 


Click on the Project tab – 
use the instructions above 
and examine some of the 
other reports in the custom 
list 

 

For Your Reference… 

To use report lists: 

1. Click on the Project tab and click on 
Reports 

2. Click on Custom and click on [Select] 

3. Click on a report and click on [Select] 

Handy to Know… 

 All reports are made up of predefined 
settings that can be altered or customised. 
As such all reports appear in the custom 
listing. 

 

1 
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The predefined reports are organised logically 
and neatly in the various categories found in the 
Reports dialog box. However, you can also see 
all of the reports listed alphabetically if this is your 

preferred way of working. The Report lists are 
found through the Custom category in the Reports 
dialog box. 
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MODIFYING AN EXISTING REPORT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J420 Reports_1.mpp... 


Click on the Project tab on 
the Ribbon and click on 
Reports in the Reports 
grouping, click on Custom 
and click on [Select] 


Scroll to and click on 
Unstarted Tasks and click 
on [Edit] to see the Task 
Report dialog box 


Click on the Definition tab 
and click on Grey bands 
until it appears ticked 


Click on the Details tab 
and change it so that the 
following settings are 
ticked: Cost, Border 
around details, and Show 
totals 


Click on [OK] to return to 
the Custom Reports 
dialog box 


Ensure Unstarted Tasks is 
still selected and click on 
[Select] to see the report in 
preview mode 


If necessary click on the 
first page to see the details 


Click on the Project tab 

 

For Your Reference… 

To modify a predefined report: 

1. Click on the Project tab, click on Reports, 
click on Custom and click on [Select] 

2. Click on the report to edit and click on [Edit] 

3. Modify the settings as appropriate 

Handy to Know… 

 It is a good idea to make a copy of a report 
definition before modifying it. You can do this 
using the [Copy] button on the Custom 
Reports listing dialog box. 

 

1 
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The predefined reports in Microsoft Project are 
actually report settings that have been created 
for you. The settings are placed in a special 
settings dialog box. This dialog box can be edited 

and the settings in it modified allowing you to tweak 
the way the report runs. Basically the settings are 
placed on three tabs – definition, details, and 
sorting order.  
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CROSSTABULATION REPORTS 
 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J420 Reports_2.mpp... 


Click on the Project tab 
on the Ribbon and click 
on Reports in the 
Reports grouping, click 
on Custom and click on 
[Select] 


Click on Cash Flow and 
click on [Select] 


Click on the first page to 
see more detail 

The Cash Flow report 
appears in a spreadsheet-
like format with tasks 
listed down the left side 
and weeks across the top. 
The report totals costs on 
a weekly basis for tasks… 


Spend a few moments 
studying the report 


Click on the Project tab 


Repeat the above steps 
and try some of these 
other crosstabulation 
reports: Crosstab, Who 
Does What When, 
Resource Usage and 
Task Usage 

 

For Your Reference… 

To run a crosstabulation report: 

1. Click on the Project tab, click on Reports, 
click on Custom and click on [Select] 

2. Click on the desired report and click on 

[Select] 

Handy to Know… 

 You can always tell a crosstabulation report 
because it appears in a spreadsheet like 
format with the data presented in a table. 

 

1 
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Several of the predefined reports in Microsoft 
Project are based upon crosstabulations. In 
crosstabulations two fields are compared 
against one another and the results are 

presented in a table format not unlike a 
spreadsheet. These types of reports are more 
sophisticated than their contemporaries and it is a 
good idea to see how they work. 

Sam
ple



Microsoft Project 2010 - Level 3 

© Watsonia Publishing Page 7 Predefined Reports 

DISSECTING A CROSSTABULATION REPORT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or 
open the file J420 
Reports_2.mpp... 


Click on the Project tab on 
the Ribbon and click on 
Reports in the Reports 
grouping, click on Custom 
and click on [Select] 


Click on Cash Flow and click 
on [Edit] to display the 
Crosstab Report dialog box 


Click on the Definition tab (if 
it is not already in view) and 
spend a few moments 
studying the settings, 
especially the fields that have 
been used 


Click on the Details tab and 
then the Sort tab and study 
the settings 


Click on [OK] to return to the 
Custom Reports dialog box 


Click on [Close] 

 

For Your Reference… 

To dissect a crosstabulation report: 

1. Click on the Project tab, click on Reports, 
click on Custom and click on [Select] 

2. Click on the desired report and click on 

[Edit]  

Handy to Know… 

 The [Text] button that appears in the 
Crosstab Report dialog box allows you to 
format the text that is used in the report. 
Here you can change the font, font size, 
colour, etc, of the text. 

 

2 

Crosstabulation reports are complex because 
they involve the interplay between two data 
fields. Basically a crosstabulation needs to 
know which field to use for the rows and which to 

use for the columns. It also needs to know the 
value to tabulate. It’s easy enough to create your 
own crosstabulation report but it is a good idea to 
dissect an existing one first. 
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CREATING A CUSTOM CROSSTABULATION 
 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous 

file with this exercise, or open 
the file J420 Reports_2.mpp... 


Click on the Project tab on the 
Ribbon, click on Reports in 
the Reports grouping, click on 
Custom and click on [Select] 


Click on [New] to display the 
Define New Report dialog box 


Click on Crosstab and click on 
[OK] to display the Crosstab 
Report dialog box 


Type Weekly Resource 
Allocation in Name 


Click on the drop arrow to the 
right of Work and click on 
Percent Allocation 


Click on And task 
assignments until it appears 
ticked 

This will display resources in 
the report and the tasks that 
they have been assigned to… 


Keep the Crosstab Report 
dialog box open for the next 
topic 

 

For Your Reference… 

To create a custom report: 

1. Click on the Project tab, click on Reports, 
click on Custom and click on [Select] 

2. Click on [New] 

3. Click on the type of report and click on [OK] 

Handy to Know… 

 There are 4 different report layouts that you 
can create as shown in the Define New 
Report dialog box: Task, Resource, 
Monthly Calendar, and Crosstab. 

 

2 
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Microsoft Project allows you to create your own 
custom reports, including the more complex 
crosstabulation variety. As with most aspects of 
design and customisation in Microsoft Project it 

is a good idea to know what you want to do before 
tackling the task. We are going to create a 
crosstabulation report that shows us our resource 
allocations over time. 

3 
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ADJUSTING THE DETAILS OF A CUSTOM REPORT 
 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

O
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 Ensure that the 

Crosstab Reports dialog 
box from the previous 
exercise is still open 
before starting this 
exercise... 


Click on the Details tab 
of the Crosstab 
Reports dialog box 


Click on Custom totals 
in Show until it appears 
with a tick 


Click on Between tasks 
in Gridlines until it 
appears ticked 


Click on the Sort tab 


Click on the drop arrow 
for Sort by and click on 
Name 


Click on [OK] to return 
to the Custom Reports 
dialog box where the 
Weekly Resource 
Allocation report should 
appear highlighted 


Click on [Select] to see 
the report in preview 
and click on the first 
page 


Click on the Project tab 

 

For Your Reference… 

To adjust the details of a custom report: 

1. Ensure the custom report dialog box appears 
on the screen 

2. Adjust the settings as desired in the Details 

and Sort tabs on the dialog box 

Handy to Know… 

 Your custom report will appear in 
alphabetical order alongside the other in-built 
reports in the Custom Reports dialog box. 

 

7 
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The hardest part to define when creating a 
custom report is the use and placement of the 
fields and their values. This is done on the 
Define tab of the dialog box. Once this is done 

you can specify the other Details and also a Sort 
order if applicable. While these are not as tricky to 
work with they can still have quite an impact on the 
way your report presents its results. 

3 
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SHARING CUSTOM REPORTS 
 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J420 Reports_3.mpp... 


Use the Open command 
on the File tab to open 
the project J420 
Reports_5.mpp 


Click on the Project tab, 
click on Reports, click on 
Custom and click on 
[Select] 


Click on [Organiser] to 
display the Organiser 
dialog box 


Click on the drop arrow 
next to Global.mpt and 
click on J420 
Reports_3.mpp so that 
both projects appear in 
the Organiser 


Click on Weekly 
Resource Allocation in 
J420 Reports_3 and click 
on [Copy] to copy it to the 
other project file 


Click on [Close] to return 
to the Custom Reports 
dialog box 


Click on [Close] 


Close all open project 
files, saving if you wish to 
do so 

 

For Your Reference… 

To share custom reports: 

1. Click on the Project tab, click on Reports, 
click on Custom and click on [Select] 

2. Click on [Organiser] 

3. Use the tools in the Organiser to copy the 
report from one file to another 

Handy to Know… 

 In the exercise above the Organiser was 
used to copy a custom report from the 
project file in which it had been created to 
another project file – that project file had to 
be open before we accessed the Organiser. 

 

5 

Custom reports are normally only available for 
use in the project file in which they are created. If 
you want to share your custom report with other 
projects you can do so using the Organiser in 

Microsoft Project. You can use the Organiser to 
copy the report to the Global template where it can 
be used by all projects, or just copy it to a specific 
project for use in that project only. 

3 The Reports tab has automatically appeared as selected 
because we have entered the Organiser from the Custom 
Reports dialog box. 
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CHAPTER 2 TEMPLATES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Templates are designed to allow you to create new files that share 
common appearances and characteristics – a common project 
DNA! A template is basically a cloning tool that uses one file to 
spawn multiple copies. 

In this session you will: 

 gain an understanding of how templates work in 
Microsoft Project 

 learn how to navigate through the available templates in 
Microsoft Project 

 learn how to save an existing project file as a template 

 learn how to use a custom template to create a new 
project file 

 learn how to create a template shortcut in the My 
Templates dialog box 

 learn how to manage the My Templates window 

 learn how to open a template for editing 

 gain an understanding of the Global template 

 learn how to copy elements into the Global template 
using the Organiser 

 learn how to apply an item from the Global template to a 
project 

 learn how to delete an item from the Global template. 
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UNDERSTANDING TEMPLATES 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Every project file that you create in Microsoft 
Project is based upon a template – a template is 
simply a cloning file that is used to create copies 
of itself. Templates can be bland, such as the 

blank template which is commonly used to create 
new project files, or quite sophisticated such as the 
ones you can download from Office.com on the 
Web. 

Your Choice of Templates 

When you use the New command on the Backstage (which is accessed from the File tab on the 
Ribbon) you are presented with several options for creating your new project. You can, for example, 
create your project: 

 using the standard Blank project template 

 using templates you’ve accessed recently 

 using templates placed in a special folder on your computer and referenced as My 
templates 

 using existing Microsoft Project or Microsoft Excel files 

 using SharePoint task lists 

 using templates that have been uploaded by Microsoft and also other project users to 
Office.com 

Unlike previous versions of Microsoft Project, Project 2010 ships with very few built in or supplied 
templates of its own. Instead Microsoft now want you to download files if you want to use existing 
templates. 

Understanding What “My Templates” Is Really All About 

The majority of project users will create their new projects using the Blank project template – it’s a 
clean, no-fuss way of starting a fresh project. 

However, if you are creating similar projects over and over again you can actually save one as a 
template and then use it to create future ones. This is great because you can add your corporate 
branding, and standard tasks and/or resources, without having to do this over and over again.  

When you save a file as a template it will save it to where Microsoft thinks is the storage place for all 
Office 2010 templates – unless this has been changed this folder will be: 

C:\Users\<User Name>\AppData\Roaming\Microsoft\Templates 

You can then access this template again through the My templates setting in Available Templates 

on the Backstage as shown above. 
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