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CHAPTER 1 PROJECT VIEWS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The main way of displaying your data with Microsoft Project is with 
views and there are really many more options and variations and 
flavours here than you may first perceive. 

Views allow you to juxtapose tasks and resources. For example, 
you can choose a view that shows tasks, or one that shows 
resources, another that shows tasks and the resource required for 
each task, or another that shows resources and the tasks that each 
is working on. 

In this session you will: 

 gain an understanding of project views 

 learn how to work with the standard built-in views in 
Microsoft Project 

 learn how to split the views on the screen 

 learn how to create a custom view 

 learn how to create a custom split view 

 learn how to display custom views 

 learn how to display views on the view menus 

 learn how to save the current settings as a new view 

 learn how to delete unwanted views from a project 

 learn how to keep views local. 

INFOCUS 
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UNDERSTANDING PROJECT VIEWS 
 

 

 

Whenever you are working in Microsoft Project 
you are viewing your project data. There are 
different types of views – for example you may 
be viewing tasks or resources, you may have a 

full screen view or a split screen view. Options for 
changing views can be found on the Task tab, the 
Resource tab, as well as the totally dedicated 
View tab on the Ribbon. 

Built-In Project Views 

Microsoft Project contains 27 different built-in views for you in its default mode. Seven of these views 
are available from the Task Views and Resource Views groupings on the View tab, while the full 27 
are available from the More Views dialog box. Here’s a list of the 27 views – the ones marked with a 
(Task) or (Resource) are accessible directly from the View tab of the Ribbon. 

Bar Rollup  Multiple Baselines Gantt Task Details Form 

Calendar (T) Network Diagram  (T) Task Entry 

Descriptive Network Diagram Relationship Diagram Task Form 

Detail Gantt Resource Allocation Task Name Form 

Gantt Chart (T) Resource Form Task Sheet 

Gantt with Timeline Resource Graph Task Usage (T) 

Levelling Gantt Resource Name Form Team Planner (R) 

Milestone Date Rollup Resource Sheet (R) Timeline 

Milestone Rollup Resource Usage (R) Tracking Gantt 

 Components of a View 

Views are presented either in a tabular format (similar to a spreadsheet screen) or in a form style. 
These are the macro or big-ticket items that views are comprised of.  

There are also micro items that determine how or what data is displayed in the sheets or forms. 
These are tables, filters, groups and layouts (in the case of forms). 

Split or Combination Views 

Microsoft Project actually allows you to display a full-screen view or a split-screen view. If you are 
interested only in tasks or resources you would most likely use a full-screen view. However, if you 
want to work with both tasks and resources at the same time a split-screen view is very useful. 

A split-screen view divides the screen horizontally and is easily created using the options in the Split 
View group on the View tab. Here you can nominate which view you’d like for the top split (also 
known as the primary view) and which for the bottom (known as the details view). When the screen 
is split a dividing bar that separates the top from the bottom can be dragged up or down to make 
either view larger or smaller than the other. 

Custom Views 

There’s a lot you can change when viewing your project. Should you find that you hit upon the perfect 
view, with either a full-screen or split-screen layout, with tables and filters that hit just the right 
buttons, then you can opt to save this view as a custom view. The custom view will be added to the 
More Views dialog box and can always be accessed again from there saving you the hassle of 
remembering which macro and micro elements you’ve used. 

Project Templates 

Like most other software applications a project file is based upon a template. Unless you specify 
otherwise your project will be created using the Global template. Any custom views that you create 
will be placed in this template so that the custom view can be used with other project files that you 
develop. 
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WORKING WITH STANDARD VIEWS 
 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Before starting this 
exercise you MUST 
open the file J415 
Views_1.mpp... 


Click on the View tab 
on the Ribbon and 
click on Calendar in 
the Task Views group 


Click on the next 

month  and 

previous month  
buttons several times 
to scroll through the 
months 


Click on Resource 
Sheet in Resource 
Views to see the 
resources used in the 
project 


Click on Other Views 
and click on More 
Views to see the More 
Views dialog box 

Notice that the current 
view is selected in the 
list… 


Scroll to and click on 
Task Sheet then click 
on [Apply] 


Click on Gantt Chart 
in Task Views to 
return to this, the most 
commonly used view 

 

For Your Reference… 

To display the standard, built-in views: 

1. Click on the View tab on the Ribbon 

2. Click on Other Views and click on More 
Views 

3. Scroll to and click on the desired view then 
click on [Apply] 

Handy to Know… 

 We’d strongly suggest that you make the 
time and give all 27 views in the More Views 
dialog box a good workout. You’ll be 
surprised by the breadth and scope of the 
view options here. 

 

1 

The standard views that are built into Microsoft 
Project are really quite extensive and allow you to 
view the tasks and resources that make up your 
project in many different ways. Most are single 

screen while some are split screen. These views 
can be accessed from the Task, Resource, or 
View tabs on the Ribbon. With most of them you’ll 
need to open the More Views dialog box. 

4 

Calendar view shows the tasks of your project as bars 
overlaid on a calendar. 
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CREATING SPLIT VIEWS 
 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the previous 
file with this exercise, or 
open the file J415 
Views_1.mpp... 


Ensure that the Gantt Chart 
view is currently active 


Click on the View tab on the 
Ribbon and click in the 
Details tick box in the Split 
View group 


Click on the drop arrow next 
to Task Form in the Split 
View group and click on 
Resource Sheet in the lower 
view 


Click on Lay Foundations to 
see the resources required 
for this task 


Click on Other Views in the 
Task Views group (on the 
Ribbon) and click on Task 
Sheet to see a task sheet 
view in the top pane 


Right click on the Resource 
Sheet selection pane in the 
lower split and click on 
Resource Usage to see a 
resource usage in the lower 
pane 


Click on Details in the Split 
View group to remove the 
tick and click on Gantt Chart 
in the Task Views group 

 

For Your Reference… 

To display a split screen: 

1. Click in the Details tick box in the Split View 
group on the View tab 

2. Click on the drop arrow to choose the 
desired view for the lower pane 

Handy to Know… 

 In split view the options on the Format tab 
on the Ribbon work on the view where the 
selection bar is darkened. The options on the 
View tab work only on the top pane 
irrespective of which selection bar (i.e. upper 
or lower) is darkened. 

 

2 

In Microsoft Project you can split your screen so 
that it shows two views concurrently. When you 
have two views the screen is split into an upper 
pane and a lower pane. A dark vertical bar, 

known as the selection bar, appears at the left of 
the pane that is currently the active pane – the 
active pane is the one that is changed when you 
use any of the commands on the Ribbon. 

4 

Here the Gantt Chart has remained in the top pane 
and a Task Form has appeared in the lower pane. 
The black vertical bar at the left of the Gantt Chart is 
the selection bar…… 
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CREATING A CUSTOM VIEW 
 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous 

file with this exercise, or open 
the file J415 Views_1.mpp... 


Click on the View tab on the 
Ribbon, click on Other Views 
and click on More Views to 
see the More Views dialog 
box 


Click on [New] to display the 
Define New View dialog box 


Click on Single View and click 
on [OK] to display the View 
Definition dialog box 


Type Cost Gantt in Name and 
ensure that Gantt Chart is 
selected in Screen 


Click on the drop arrow  for 
Table and click on Cost, click 
on the drop arrow  for 
Group and click on No Group, 
and click on the drop arrow  
for Filter and click on All 
Tasks 


Click on [OK] to return to the 
More Views dialog box 

Notice that the custom view 
appears in the box… 


Ensure Cost Gantt is selected 
and click on [Apply] to see the 
new view 

 

For Your Reference… 

To create a custom view: 

1. Click on the View tab, click on Other Views 
and click on More Views 

2. Click on [New], click on Single View and 
click on [OK] 

3. Enter the appropriate settings 

Handy to Know… 

 The title bar of the View Definition dialog 
box indicates in which project file the view is 
being created. The Organiser button in this 
dialog box allows you to shift this view to 
other locations. 
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2 

A view is made up of a screen layout, a table, a 
group, and a filter. The existing views in 
Microsoft Project have all been created with 
these elements. You can create your own 

custom views in Microsoft Project by specifying in 
the Define New View dialog box which of these 
elements you’d like.  

5 

6 Sam
ple



Microsoft Project 2010 - Module 2 

© Watsonia Publishing Page 6 Project Views 

CREATING A COMBINATION VIEW 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J415 Views_2.mpp... 


Click on the View tab on 
the Ribbon, click on 
Other Views and click on 
More Views to see the 
More Views dialog box 


Click on [New] to display 
the Define New View 
dialog box, click on 
Combination View and 
click on [OK] 


Type Resource Costs in 
Name 


Click on the drop arrow 

 for Primary View and 
click on Resource Sheet 


Click on the drop arrow 

 for Details Pane and 
click on Cost Gantt 


Click on [OK] to return to 
the More Views dialog 
box, ensure Resource 
Costs is selected and 
click on [Apply] 


Click on the various 
resources in the top pane 
and study their various 
costs in the Details pane 
at the bottom 

 

For Your Reference… 

To create a custom split view: 

1. Click on the View tab, click on Other Views 
and click on More Views 

2. Click on [New], click on Combination View 
and click on [OK] 

3. Enter the appropriate settings  

Handy to Know… 

 Once a custom combination view has been 
created it can also be selected from the 
Details settings in the Split View grouping 
on the Ribbon. 

 

6 
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Microsoft Project allows you to create both 
single-screen custom views and split-screen 
custom views. When you create a single-screen 
custom view you can specify which screen, filter, 

group, and table to use. When you specify a split-
screen view you can only select the view screen 
layout to use in the upper and lower panes. 

5 

When a resource is selected in the top pane all of the tasks 
and associated task costs for that resource will appear in the 
bottom pane… 
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USING CUSTOM VIEWS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous 

file with this exercise, or open 
the file J415 Views_3.mpp... 


Click on the View tab on the 
Ribbon and click on Details in 
Split View until it appears 
without a tick – this will ensure 
that  we have a single screen 
view 


Click on the drop arrow for 
Gantt Chart in the Task 
Views group to display a menu 
of views 


Click on Cost Gantt to see the 
custom Cost Gantt view 


Click on the drop arrow next to 
Resource Sheet in the 
Resource Views group to 
display a menu of resource 
views 


Click on Resource Costs to 
display the custom split-screen 
view 


Click on Details in Split View 
until it appears un-ticked 


Click on Other Views in the 
Task Views group and click on 
More Views 


Scroll up to and click on Cost 
Gantt and click on [Apply] 

 

For Your Reference… 

To display a custom view: 

1. Click on an appropriate resource or task view 
on the View tab that will display a menu of 
views 

2. Click on the desired custom view 

Handy to Know… 

 If the custom views have not appeared in the 
menus (as shown above) then the Show in 
menu setting must have been unticked when 
the custom view was being defined. 

 Remember, if you can’t find a view on the 
menu it will always be in the More Views 
dialog box. 

 

2 

Once custom views have been created they are 
ready for use. When a custom view is created, 
the Show in menu setting in the View Definition 
dialog box is automatically on, which means that 

the view should appear in either the Resource or 
the Task menus. If you can’t find the custom view 
on the menu it will always appear in the More 
Views dialog box. 
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USING CUSTOM VIEWS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Before starting this exercise 

you MUST open the file J415 
Views_3.mpp... 


Click on the View tab on the 
Ribbon and click on Details in 
Split View until it appears 
without a tick – this will ensure 
that  we have a single screen 
view 


Click on the drop arrow for 
Gantt Chart in the Task 
Views group to display a menu 
of views 


Click on Cost Gantt to see the 
custom Cost Gantt view 


Click on the drop arrow next to 
Resource Sheet in the 
Resource Views group to 
display a menu of resource 
views 


Click on Resource Costs to 
display the custom split-screen 
view 


Click on Details in Split View 
until it appears un-ticked 


Click on Other Views in the 
Task Views group and click on 
More Views 


Scroll up to and click on Cost 
Gantt and click on [Apply] 

 

For Your Reference… 

To display a custom view: 

1. Click on an appropriate resource or task view 
on the View tab that will display a menu of 
views 

2. Click on the desired custom view 

Handy to Know… 

 If the custom views have not appeared in the 
menus (as shown above) then the Show in 
menu setting must have been unticked when 
the custom view was being defined. 

 Remember, if you can’t find a view on the 
menu it will always be in the More Views 
dialog box. 

 

2 

Once custom views have been created they are 
ready for use. When a custom view is created, 
the Show in menu setting in the View Definition 
dialog box is automatically on, which means that 

the view should appear in either the Resource or 
the Task menus. If you can’t find the custom view 
on the menu it will always appear in the More 
Views dialog box. 

4 Sam
ple



Microsoft Project 2010 - Module 2 

© Watsonia Publishing Page 9 Project Views 

CUSTOMISING THE VIEW MENUS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Before starting this exercise 

you MUST open the file J415 
Views_4.mpp... 


Click on the View tab on the 
Ribbon and click on the Gantt 
Chart drop arrow in the Task 
Views group 


Click on More Views to 
display the More Views dialog 
box 


Click on Detail Gantt and click 
on [Edit] to display the View 
Definition dialog box 


Click on Show in menu until it 
appears ticked and click on 
[OK] 


Repeat steps 3 and 4 for the 
Gantt with Timeline, 
Levelling Gantt, and Multiple 
Baseliness Gantt Views 


Click on [Close] to close the 
More Views dialog box 


Click on the Gantt Chart drop 
arrow to see these views now 
appear on the menu 


Click on Gantt Chart 

 

For Your Reference… 

To put views on a menu: 

1. Click on the view in the More Views dialog 
box and click on [Edit] 

2. Tick the Show in menu setting to see the 
view on the menu 

3. Click on [OK] 

Handy to Know… 

 Views can be removed from the menu again 
simply by unticking the Show in menu 
setting in the View Definition dialog box. 

 Views where the primary screen is based on 
tasks will appear on Task menus, while ones 
with resource primary screens will appear in 
Resource menus. 

 

7 

The View Definition dialog box is used to create 
custom views. But it can also be used to make 
changes to existing views in a project. One of the 
settings on the dialog box, Show in menu, 

determines whether the view is displayed in a 
menu list on the Ribbon. You can use this setting 
to perform a rudimentary customisation of the 
menus so that they show only the views you want. 

3 
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SAVING AN EXISTING VIEW 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 Continue using the previous 

file with this exercise, or open 
the file J415 Views_5.mpp... 


Click on the View tab on the 
Ribbon, click on the Gantt 
chart drop arrow in the Task 
Views group and click on 
Gantt Chart 


Click on the Tables drop arrow 
in the Data group and click on 
Work to use the Work table in 
the view 


Drag the table divider across 
until the first three columns are 
clearly visible 


Click on the Gantt Chart drop 
arrow and click on Save View 
to display the Save View 
dialog box 


Ensure Save as a New View 
is selected, type Gantt with 
Work and click on [OK] 


Click on the Gantt Chart drop 
arrow and notice that the new 
view appears 


Click on Gantt Chart, click on 
the Tables drop arrow and 
click on Entry to restore the 
original table to this view 

 

For Your Reference… 

To save an existing view: 

1. Define the screen elements in the way you 
wish 

2. Click on the Gantt Chart drop arrow and 
click on Save View 

3. Type a name for the view and click on [OK] 

Handy to Know… 

 In the screen show above, the new view 
appears ticked in the menu – this indicates 
that it is the currently active view. 

 

6
1 

4 

Custom views can be created by manipulating 
settings in the View Definition dialog box. 
However, the downside of this is that you can’t 
see what these changes are doing until you 

actually apply the custom view. Microsoft Project 
allows you to save all of the settings currently on 
your screen into a custom view – this process 
effectively allows you to prototype a view. 

3 
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DELETING UNWANTED VIEWS 
 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J415 Views_6.mpp... 


Click on the View tab on 
the Ribbon, click on 
Other Views in Task 
Views and click on More 
Views 


Click on [Organiser] to 
display the Organiser 
dialog box 


Click on Cost Gantt on 
the right and click on 
[Delete] to receive a 
warning message 


Click on [Yes] 

Notice that the view still 
appears in the Global 
template even though it 
has been deleted from the 
project file on the right… 


Click on Cost Gantt on 
the left, click on [Delete] 
and click on [Yes] 


Click on [Close] to close 
the Organiser, then 
[Close] to close the More 
Views dialog box 


Click on the Gantt Chart 
drop arrow and notice that 
the Cost Gantt has gone 

 

For Your Reference… 

To delete a view: 

1. Click on the View tab, click on Other Views, 
click on More Views, then click on 
[Organiser] 

2. Click on the name of the view and click on 
[Delete] 

Handy to Know… 

 When you create a custom view it is 
automatically added by Microsoft Project to 
the global template so that it can 
immediately be used by other projects you 
create. You must remember to delete it from 
the current project as well as the global 
template if you no longer need that view. 

 

2 

Custom views can be created for permanent or 
temporary use. The problem is that once you get 
the hang of custom views there is a good chance 
you’ll readily and quickly create them for all forms 

of usage. There comes a time however when a bit 
of management and maintenance is required. You 
can delete unwanted views in Microsoft Project 
through the special Organiser facility. 

4 

This dialog box shows the views in the Global template on 
the left and in the current project on the right… 
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KEEPING NEW VIEWS LOCAL 
 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J415 Views_6.mpp... 


Click on the File tab on 
the Ribbon and click on 
Options to display the 
Project Options dialog 
box 


Click on the Advanced 
tab at the left 


Click on Automatically 
add new views, tables, 
filters, and groups to 
the global until it 
appears without a tick 


Click on [OK] 

 

For Your Reference… 

To keep views local: 

1. Click on the File tab on the Ribbon and click 
on Options 

2. Click on the Advanced tab 

3. Un-tick Automatically add new views, 
tables, filters, and groups to the global 

Handy to Know… 

 If you are sharing your copy of Microsoft 
Project with other users then you should 
keep your own views, tables, filters, etc, 
local. Local just means that they will be 
saved to your file rather than to the global 
template. 

 

Microsoft Project automatically saves new 
views, tables, filters, and groups to the global 
template so that they are available to other 
projects you create. If you are working with other 

people however, this process can cause grief as 
each one of you applies your own custom features 
to Microsoft Project. The automatic saving to the 
global template can be switched off. 
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